Excel kaksi funktiota samaan soluun
+1
Minulla on kaava =PYÖRISTÄ.KERR.YLÖS(P33;0,5)
Mutta haluaisin siihen lisätä myös että jos tämän kaavan tulos on alle 1 niin tulos on 1.

En millään keksi miten se tehdään jotta saisin sen samaan lauseeseen. En haluaisi tehdä sitä toiseen sarakkeeseen koska joutuisin muuttamaan niin monta muuta kaavaa.

3 vastausta

Järjestä:aikapisteet
=JOS(A1>=1; PYÖRISTÄ.KERR.YLÖS(A1;0,5); 1)

Eli tuo käytännössä:
Jos solun alkio on suurempi tai yhtäsuuri kuin 1 niin pyöristää,
Muuten palauttaa 1
+1

Kommentit (1)

Tuon yhtäsuuruusmerkin tuosta voi kyllä napata pois :D tuli hiukan kiireessä vastattua vaan enkä ihan loppuun asti miettinyt. Muuten kyllä pitäisi olla ihan toimiva. - wiza
JOS funtiota hiukan tarkemmin

=JOS(ehto;JosEhtoTOSI;josEhtoEPÄTOSI)
Huomattava on, että kumpikin (ehtoTOSI tai EhtoEPÄTOSI) voi olla oma funktionsa.
Näitä voi myös ketjuttaa pitemmälle. EhtoTOSI tai EhtoTOSI voi myös olla JOS funktio jolla oma ehto ja tosi/epätosi lopputulos.(tai mikä tahansa muu funktio)
Tosin mitä useamman sisäkkäisen funktion laittaa samaan lauseeseen, sitä mielenkiintoisempaa on etsiä ja korjata kun haluaa muutoksia taulukkoon
+1

Kommentoi tätä vastausta

Excel kaksi funktiota samaan soluun (4 vastausta) - X2.fi
ffensqrne http://www.g9c9e6x30k86v23fb9e93d8cct42m7jes.org/
uffensqrne
<a href="http://www.g9c9e6x30k86v23fb9e93d8cct42m7jes.org/">affensqrne</a>
0

Kommentoi tätä vastausta